home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-admin / fam-2.7.0-r4 / fam-2.7.0-r4.ebuild < prev    next >
Text File  |  2006-04-25  |  2KB  |  91 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-admin/fam/fam-2.7.0-r4.ebuild,v 1.14 2006/03/05 03:51:15 vapier Exp $
  4.  
  5. inherit libtool eutils gnuconfig
  6.  
  7. DESCRIPTION="FAM, the File Alteration Monitor"
  8. HOMEPAGE="http://oss.sgi.com/projects/fam/"
  9. SRC_URI="ftp://oss.sgi.com/projects/fam/download/stable/${P}.tar.gz
  10.     mirror://gentoo/fam-2.7.0-dnotify.patch"
  11.  
  12. LICENSE="GPL-2 LGPL-2.1"
  13. SLOT="0"
  14. KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
  15. IUSE=""
  16.  
  17. DEPEND=">=net-nds/portmap-5b-r6
  18.     !app-admin/gamin"
  19. PROVIDE="virtual/fam"
  20.  
  21. src_unpack() {
  22.     unpack ${A}
  23.  
  24.     cd ${S}
  25.  
  26.     # large file patch #76679
  27.     epatch ${FILESDIR}/${P}-largefiles.patch
  28.  
  29.     # dnotify patch #43027
  30.     epatch ${DISTDIR}/${P}-dnotify.patch
  31.  
  32.     # Use limits correctly -#89478
  33.     epatch "${FILESDIR}/${P}-limits.patch"
  34.  
  35.     # Fix gcc 4.1 problems
  36.     epatch ${FILESDIR}/${P}-gcc41.patch
  37.  
  38.     # Fix permission problems with user* in FEATURES (#35307)
  39.     chmod u+w ${S}/configure
  40.  
  41.     gnuconfig_update
  42.     libtoolize --copy --force
  43.  
  44.     # Please do not remove this again - fixes $S and $D in libtool linker
  45.     # scripts (.la files)
  46.     elibtoolize
  47. }
  48.  
  49. src_install() {
  50.  
  51.     make install DESTDIR="${D}" || die
  52.  
  53.     dosed "s:local_only = false:local_only = true:g" /etc/fam.conf
  54.  
  55.     exeinto /etc/init.d
  56.     doexe ${FILESDIR}/famd
  57.  
  58.     dodoc AUTHORS ChangeLog INSTALL NEWS TODO README
  59.  
  60. }
  61.  
  62. pkg_postinst() {
  63.  
  64.     einfo "To enable fam on  boot you will have to add it to the"
  65.     einfo "default profile, issue the following command as root to do so."
  66.     echo
  67.     einfo "rc-update add famd default"
  68.  
  69.     # temporary warning for people upgrading
  70.     # 6-12-03 foser <foser@gentoo.org>
  71.     if [ -e /etc/init.d/fam ]
  72.     then
  73.         echo
  74.         echo
  75.         ewarn "IMPORTANT INFO FOR USERS UPGRADING FROM OLDER (<2.7.0) FAM VERSIONS :"
  76.         echo
  77.         einfo "With the 2.7.0 version the fam daemon moved to sbin and was"
  78.         einfo "renamed from 'fam' to 'famd'. These changes are for consistency"
  79.         einfo "reasons also applied to the Gentoo init script. This means you"
  80.         einfo "will have to remove fam from the default runlevel and add famd."
  81.         einfo "This can be done by issueing the following commands :"
  82.         echo
  83.         einfo "rc-update del fam"
  84.         einfo "rc-update add famd default"
  85.         einfo "rm /etc/init.d/fam"
  86.         echo
  87.         einfo "The last command removes the old init script."
  88.     fi
  89.  
  90. }
  91.